WinCnc Versions List

0.4.00a (4-25-07):

· Implemented new device driver for Windows Vista compatibility.  Preceding versions of WinCnc will be compatible with Microsoft Windows 2000/Vista/XP only.
0.4.00b (5-7-07):
· Updated tangential knife support.  The type, “knifemode=t#” can be set to ‘t1’ for normal knife function or to ‘t2’ for the new knife functionality which reduces XY stopping during knife rotation.
· Updated arc interpolation to generate at least one segment per degree of rotation.
· Updated the DA function in the device driver to improve performance.
0.4.00c (5-17-07):

· Fixed a bug found in the type ‘1’ auxiliary output control buttons, which allow changing auxiliary output states while running a GCode file.
· Fixed a bug found in tangential knife support.
0.4.00d (5-22-07):
· Fixed a problem found in serial port communications when running under Windows Vista.  (Serial Keypad, SST servo drives, DGH Analog In/Out modules).
· Fixed a problem found in the tangential knife support.
· Added three new “KeyPadOut” button types for new features added to the serial keypad.  The new button types are shown in the following example CncScrn.ini file entries:
"KeyPadOut",0,0,0,0,5,0,"RunLast","","",53,0,"" 
[Type 5: repeats last command]
"KeyPadOut",0,0,0,0,6,0,"AxUp","","",57,0,""

[Type 6: shifts the keypad axis display up]
"KeyPadOut",0,0,0,0,7,0,"AxDown","","",54,0,""
[Type 7: shifts the keypad display down]

· Added a new command M99.1 which will initiate a commanded program abort.

· Added two new wincnc.ini file entries and two new commands to add up to 10 additional alternate high or alternate low limits switches to be configured and selected by command.

The two new wincnc.ini file settings syntax are as follows:

EXALTAXISLO=C# P# B# O#

EXALTAXISHI=C# P# B# O#

C# - alternate limit channel number.  There are up to 10 low and 10 high channels available.
P# - switch port number

B# - switch bit number

O# - (0/1) sets polarity for the switch

The two new commands are shown in the following examples:

L210.1 X C2

[Select ExAltAxisLo channel 2 for the X axis]

L210.1 Y C4

[Select ExAltAxisLo channel 4 for the Y axis]

L210.1 X

[Restore original AltAxisLo settings for the X axis]

L211.1 X C2

[Select ExAltAxisHi channel 2 for the X axis]

L211.1 Y C4

[Select ExAltAxisHi channel 4 for the Y axis]

L211.1 X

[Restore original AltAxisHi settings for the X axis]

0.4.00e (6-6-07):
· Updated the DXF import feature to support newer versions of the DXF format.
· Updated the “Axis Mapping” feature.  The previous implementation of axis mapping is no longer supported; therefore the new configuration and setup must be used in this and all preceding versions.
The configuration settings in the wincnc.ini file for axis mapping are as follows:

mapping=i#

Enables axis mapping and sets the interpolation increment used for all axis.

axismap=s# e# m#
Add this line under the “axisspec=” line for each axis to be mapped.




S# sets the starting position for the map.




E# sets the ending position for the map.




M# sets the map increment used for this axis.

The commands used to setup the axis mapping are as follows:

L600 XY..

Disables mapping adjustments for specified axis.  No axis spec disables all.
L601 XY..

Enables mapping adjustments for specified axis.  No axis spec enables all.
L602 XX, XY, ..
Starts mapping setup for specified axis.  First axis specifies the axis to map and



the second axis specifies the axis to adjust.  The axis to map will automatically




move to the start map position.  No axis spec stops the mapping setup.

L603 {NPSE}
Stores the current adjustment and moves the map axis to the specified map increment.  N is next, P is previous, S is start and E is end.  The default move is to the next map increment position.

L604 {NPSE}
Moves the map axis to the specified map increment.  N is next, P is previous, S is start and E is end.  The default move is to the next map increment position.

L605

Store the current adjustment.
The following is a sample procedure for setup of an axis map:

L600

[Disable mapping adjustment for all axis]

L602 XY

[Start mapping setup for the X axis with adjustments on the Y axis]

L603

[Store adjustment and move to the next map increment]

….


[Repeat until the end of the map is reached]

L602

[Stop mapping setup]

L601

[Enable mapping adjustment for all axis]

0.4.00f (6-13-07):
· Updated feed rate override velocity matching to improve smoothness.
0.4.00g (6-14-07):
· Updated G54/G55/G56/G57 code to fix a problem found with the type 3 rotating vertical head.
2.4.00 (6-18-07):
· Contains all features and fixes up to test version 0.4.00g.
0.4.01a (6-20-07): 
· Fixed a bug found in the cutter diameter compensation arc/arc intersection calculations.
0.4.01b (6-28-07):
· Updated G54/G55/G56/G57 code to modify support for the type 3 rotating vertical head.
· Fixed a bug found in the bitmap engrave positioning and alignment offset when using a metric unit of measure.
· Fixed a problem with the GCode/Bitmap viewer when using unit of measure conversion commands. 
0.4.01c (7-11-07):
· Updated IO functions in the device driver for compatibility with PCI devices other than the PCI7200.
· Updated the demo mode functionality to improve performance and fix driver issues.
· Added a new Stair Stringer software enable Level 3 for batch optimization.
· Reduced the maximum motion buffer size to decrease the amount of RAM required by WinCnc.
· Updated the manual digitization feature to store the last output type, directory and file name.
· Added support for laser engraving and carving using a rotary axis.  Parameters have been added to the “laser=” line in the wincnc.ini file.
Laser=… A# B# R#

A# sets the primary (raster) axis number.  0 is X, 1 is Y, etc..

B# sets the secondary (row) axis number.  0 is X, 1 is Y, etc..

R# sets the default radius of the engraving surface when a rotary axis is used.

· Updated the L256 command to allow the radius for rotary axis engraving to be changed.

L256… R#

R# sets the radius used for rotary engraving in the current unit of measure.

0.4.01d (8-7-07):
· Updated Demo mode to prompt for demo mode if a supported PCI card is not found.
· Updated the File->Restart dialog box to save the last 10 files executed, along with their G92 offsets, completion status and last line number.
· Updated the File->Digitize->Automatic dialog box with a “false bottom” value which is implemented as the lowest possible Z position that can be digitized.
· Updated the parsing of the CncScrn.ini file to make all settings case insensitive.
· Added support for an optional new PCI card, which can be used as a replacement for the PCI7200/daughterboard combination.  The new wincnc.ini file setting is Timertype=PCI7200 for the older PCI7200/daughterboard combination or Timertype=WINCNC for the new PCI card.  The PCI7200/daughterboard combination is the default setting.
· Updated cutter diameter compensation to fix a problem found in calculation of tangent arc intersection.
0.4.01e (8-17-07):
· Fixed a problem found in bitmap engraving when using large high resolution images.
· Fixed a problem found in bitmap engraving where the bitmap origin was shifted in the positive direction at high speeds.
· Updated the transit moves to exclude laser and tangential knife features.
0.4.01f (8-29-07):
· Fixed a problem with rapid (G0) moves while in G54/G55/G56/G57 mode when using the BonC rotating spindle type 5.
· Fixed a problem found in the cutter diameter compensation with tangent arc intersections.
· Added two new button types to the CncScrn.ini file.  AuxOutEx and StateBtnEx.  These buttons are identical to the old AuxOut and StateBtn buttons, except for the addition of a second bitmap name parameter. When using these button types the first specified bitmap will be displayed on the button surface when the button state is on and the second bitmap is used when the button is in the off state.  The following are examples of each new button type entry in the CncScrn.ini file:
”AuxOutEx”, 5, 5, 50, 50, 1, 0, “”, “M11C1”, “M12C1”, -1, -1, “C1ON.BMP”, “C1OFF.BMP”, 1
”StateBtnEx”, 5, 5, 50, 50, 10, 0, “”, “L34”, “L35”, -1, -1, “TON.BMP”, “TOFF.BMP”, 1
0.4.01g (9-10-07):
· Fixed a problem found when using the G53 command while cutter compensation is active.
· Fixed a problem found when using the M28 or M29 command while running a GCode file where soft limits and boundaries were disabled for the remainder of the file execution.
· Added large toolbars for easier touch screen configuration of WinCnc.
· Added automatic recognition of DXF/HPGL files.  When the user attempts to run a DXF or HPGL file the appropriate File->Import dialog is opened automatically.
· Added a new “axisbrake=” setting to the wincnc.ini file to support axis that use a braking system which needs to be activated when an axis is not moving and deactivated when the axis moves.  Syntax for the wincnc.ini file is as follows:
AXISBRAKE=C# D#

C# specifies the auxiliary output channel used to activate/deactivate the brake.

D# specifies the dwell time, in seconds, needed to allow the brake to deactivate before moving.

NOTE:  The “axisbrake=” line should appear after the “axisspec=” line for the axis with which the brake should be associated, prior to the “axisspec=” line for the next configured machine axis.  The default polarity for the brake output is off for brake activation and on for brake deactivation.  The polarity may be inverted on the auxiliary output configuration if needed.

2.4.01 (9-11-07):
· Contains all features and fixes up to test version 0.4.01g.
· Fixed a problem found in the G28 command which would result in a soft limit exceeded error.
0.4.02a (9-14-07):
· Added a DXF output option to the touch probe outline digitization feature.
· Added a new setting to the “SST=” line in the wincnc.ini file.  Syntax for the wincnc.ini file is as follows:
SST=C# D#

C# is the COM port number used to connect to the SST servo drives.

D# is an additional dwell amount (in seconds) to be included when using the “gearshift” feature.

0.4.02b (9-21-07):
· Updated the dwell (G4) function to provide accuracy up to 0.005 seconds.
· Fixed a problem found in the tangential knife support, which caused improper knife rotation in arcs.
0.4.02c (9-27-07):
· Fixed a problem with automatic detection and port assignments when using the PCI24H or PCI48H.
· Updated limit switch configuration to require port assignments on the PCI7200 or daughter board only.
· Fixed a bug found with the automatic update codes generation on startup for older WinCnc versions and dated expiration, which caused a WinCnc program crash.
0.4.02d (10-7-07):
· Updated the SST GearShift feature to work without requiring a COM port connection to the SST drives.  Set the “SST=C#” to “C0” to enable the gearshift feature without the COM port connection.  Also, set the “SST=D#” to the maximum RAS setting from the drives using the GearShift feature, adding 0.01 seconds to prevent drive faults.  When using this feature without the serial loop cable the SST drive parameters must be set manually.
· Updated the “SSTNODE=” line to support “D#” settings between 0 and 8.  This is an integer only field and will not accept fractional numbers.
0.4.02e (10-17-07):
· Fixed a bug found in the maximum current setting in the tool library.

· Added a new max RPM setting to the tool library.  This setting allows the user to specify an RPM limit for each tool.

· Added a feature enable for the WinHinge parametric application.

· Added shortcut keys to the THC target voltage.  The plus (+) and minus (-) keyboard keys can be used to adjust the target THC voltage up and down.

0.4.02f (10-24-07):
· Fixed a problem found in homing alternate axis where a soft limit error could occur during G28.

· Fixed a problem found in homing alternate axis where the secondary axis would stop too quickly when contacting the limit switch.
2.4.02 (10-25-07):
· Contains all features and fixes up to test version 0.4.02f.

0.4.03a (11-12-07):
· Updated the COM DLL interface, removing old functions and improving the ‘InMotion’ performance.

· Added support for the new Optimet MarkIII laser probe.  Support for the MarkIII device is configured in the wincnc.ini file by adding ‘T1’ to the “laserscan=” line.

· Fixed a problem found in the GCode/BMP viewer where WinCnc could not process a GCode or Bitmap file when minimized or hidden by another application window.

· Fixed an issue found in the automatic arc interpolation used for axis mapping or helical moves where minimum line segment length was needed.

· Added support for a laser height control system using a 0-10v+ analog signal and the DGH-D1141 serial module.  This system uses the serial module to monitor voltage changes and signal height adjustments as needed.

Syntax for the wincnc.ini file is as follows:

LHC=T# A# C# V# F# U# D#

T# - Must be 1 (For future use).

A# - Axis to adjust (X=0, Y=1, Z=2, etc).

C# - COM port number of the DGH-D1141 serial module.

V# - Voltage change tolerance.

F# - Adjustment velocity (units/min).

U# - Input channel for “move-up” signal from the DGH-D1141.

D# - Input channel for “move-down” signal from the DGH-D1141.

A new command, L822 was added for use with this feature.  After positioning the laser at the desired height the L822 command should be ran to store the target voltage for the height control.

0.4.03b (11-12-07):
· Updated the L6 and L7 acceleration commands to include both rapid and feed accelerations.
· Added a two new commands, L6.1 and L6.2 commands to set rapid and feed accelerations.  Syntax for these commands are as follows:

L6.1 X500 Y500
[Sets X and Y rapid accelerations to 500 units/min/sec]

L6.2 Z300

[Sets Z feed acceleration to 300 units/min/sec]

· Updated the tangential knife enable (L30) command to include two new parameters.  Syntax for this command is as follows:  L30A#Z#, where A# sets the auto-lift angle and Z# sets the auto-lift distance.

· Added two new commands, L922 and L923 to enable/disable the SST “gearshift” feature.  L922 enables automatic “gearshift” and L923 disables the automatic “gearshift”.

· Updated the L822 command used with the laser height control adding a dwell to allow time for the DGH analog monitor device to process serial commands.

· Fixed a problem found in the cutter diameter compensation where intersecting small radius arcs no longer intersect after compensation.

· Fixed a problem found in the tangential knife support where the knife would lift unnecessarily during a full G2/G3 circle move. 
0.4.03c (11-29-07):
· Fixed a problem found in the tangential knife support (types 1 and 2) where an unnecessary pause in motion could occur when cutting an arc through the 0/360 degree knife position.

· Fixed a problem found in the COM DLL support where the initialization function call would succeed, even when the WinCnc software did not have COM DLL communications enabled.
0.4.03d (12-05-07):
· Updated the tangential knife feature to support a rotating knife where the up/down position is controlled by an auxiliary output channel, instead of a vertical Z axis.  New settings have been added to the “knifemode=” line in the wincnc.ini file.  Syntax is as follows:

knifemode=…N# C# D#

N# - Specifies the axis number of the rotating knife. (On XYZW machine Z=2/W=3).
C# - Specifies the auxout channel number used to raise/lower the knife.

D# - Specifies the time (seconds) that the knife needs to raise/lower.

· Added a new setting to the “altaxisspec=” line in the wincnc.ini file.  Adding an ‘L#” value to the line will cause alternate limits to be initially enabled/disabled.  L0 will set alternate limits to be initially disabled and L1 sets the alternate limits to be initially enabled.  By default alternate low and high limit switches are enabled for the axis when and “altaxisspec=” line is used.
· Fixed a problem found with using the “DEMOMODE=#” setting in the wincnc.ini file.  In cases where the PCI7200 card was already installed WinCNC would ignore the forced demo mode and start normally.
· Added tool times to the log file output.  If configured WinCNC will add tool times for tools 1-10 for the first and/or second tool changer.
0.4.03e (12-21-07):
· Updated the tangential knife feature.  Removed the ‘A#’ and ‘Z#’ specs from the L30 command, used to set the auto-lift angle and height.  Added a new command, L30.1 A# Z# C# D# to set parameters used for the tangential knife support.

L30.1 A# Z# C# D#

A# - Sets the maximum angle of rotation without lifting the knife.

Z# - Sets the height to lift the knife when a vertical axis is used.

C# - Sets the auxiliary output channel number used to control the knife.

D# - Sets the dwell used when the knife up/down position is controlled by auxiliary output.

· Update the L83 command which is used to spot digitize and record the position to a text file SCAN.CSV.  An ‘A#’ parameter was added to specify appending the file.  When ‘A1’ is used the file will be appended with the new position information, without the ‘A’ parameter the file is cleared each time and the new value is written.
· Fixed a problem found in the cutter diameter compensation support.  When adjusting two vectors that originally intersected, so that they no longer intersect, then an arc move is added to connect the two lines.  If the distance of the connection move needed is very small then a line may be added to connect the two moves.
0.4.03f (1-17-08):
· Updated the tangential knife support to include a pre-rotation of the knife.  This should help to reduce the amount of deceleration needed to handle vectors where the needed knife rotation does not require lifting the knife.
· Added automatic up/down positioning of the tangential knife.  When using the automatic positioning the knife will be commanded down (M11/G1Z0) for a G1/G2/G3 move and up (M12/G1Z#) for G0/G53 moves.  Syntax for the wincnc.ini file is as follows:

knifemode=… m#

m# can be 1 for automatic up/down positioning or 0 (default) for manual knife up/down.

· Added new “RPTCMD” buttons for laser power and spindle speed, needed by configurations that include both.  “RPTCMD” button syntax is described in the following examples:

"RptCmd",0,5,60,20,3,0,"LASER+","","",-1,-1,""
[Type 3 – Laser Power Increase]

"RptCmd",0,65,60,20,4,0,"LASER-","","",-1,-1,"" 
[Type 4 – Laser Power Decrease]

"RptCmd",0,125,60,20,5,0,"SPIN+","","",-1,-1,"" 
[Type 5 – Spindle Speed Increase]

"RptCmd",0,185,60,20,6,0,"SPIN-","","",-1,-1,"" 
[Type 6 – Spindle Speed Decrease]

· Updated support for “on-the-fly” axis position adjustment used by laser and torch height control systems.  A step position rounding issue was causing vertical axis to loose position over time in some cases.
2.4.03 (1-17-08):
· Contains all features and fixes up to test version 0.4.03f.

0.4.04a (1-25-08):
· Updated the G28 command to improve accuracy of homing dual motor axis.

· Updated the G28 command to use a rapid move to retract axis after the initial limit contact.

· Updated the G28 command to initialize SST “gearshift” mode properly before homing.

· Updated the L30/L31 commands to work properly when simulating or previewing a GCode file.

· Added new internal variables AP0/AP1/AP2/AP3/AP4/AP5 to access absolute axis positions for use in macros used for tool and material measurement.

0.4.04b (2-11-08):
· Updated the ICutDriver.DLL to resolve issues with WinCNC/ICut communications.

· Updated the G28 command to resolve issues with rotational axis and unit conversion.

· Updated the G28 command to automatically disable feature such as knife rotation, axis adjustment, axis mapping, etc. during the homing process.

· Updated the file restart feature to resolve an issue with using the auto-preview mode during a file restart.

· Updated the file restart feature to resolve an issue where the last line number stored for a file would not update properly if the file was started from the file restart dialog.

· Fixed a bug found in the rotational digitization using the Optimet laser scanner.

· Added improved synchronization functionality to the communications DLL.
· Updated the THC feature to smooth and average the voltage read from the plasma unit.
· Updated G54/55/56/57 to accept standard workspace offset type setting (T0) in the wincnc.ini.
· Updated the manual digitize feature to fix a bug found when outputting the digitized data to GCode.

· Updated the manual digitize feature adding new “JobCmd” button types(7-11) to map the manual digitization functions to the hand-held serial keypad.  The following are examples of the new button types in the cncscrn.ini file:

[“Button Type” xstart, ystart, xsize, ysize, type #, label, unused, unused, scanon, scanoff, bitmap]

[*Note: using 0 for xsize and ysize will make the button not visible on the WinCNC screen]

"JobCmd",0,0,0,0,7,0,"Rapid","","",1,0,""

"JobCmd",0,0,0,0,8,0,"Feed","","",2,0,""
"JobCmd",0,0,0,0,9,0,"Arc","","",3,0,""
"JobCmd",0,0,0,0,10,0,"Close Shape","","",4,0,""
"JobCmd",0,0,0,0,11,0,"Undo","","",5,0,""
0.4.04c (3-28-08):
· Updated the L600/L601 commands used to enable/disable axis mapping.  The L600 command should be used before performing operations that involve limit switch contacts such as homing (G28), digitizing, tool measuring etc..

· Updated the torch height control system to support an alternate pierce delay to be used if the plasma torch has been off for longer than a specified period of time.  Some torch models may require a longer pierce delay if the torch has been inactive for some time.  These values can be specified in the THC configuration dialog box, where the “Cold Time” is the number of seconds the torch must be inactive to qualify for the alternate pierce delay and the “Cold Delay” is the number of seconds to use for a “Cold” pierce.  If a zero ‘0’ value is specified for the “Cold Time” then the standard pierce delay is always used.  The default “Cold Time” and “Cold Delay” can also be specified in the wincnc.ini file on the “THC=” line.  The syntax for these settings is as follows:
THC=…C# D#
C# is the “Cold Time” in seconds.

D# is the “Cold Delay” in seconds.

· Fixed a problem found in the “smart” bitmap raster engraving feature where bitmap data lines were being misplaced when blank rows were skipped.
0.4.04d (4-08-08):
· Fixed a problem found in the smoothing feature when using interpolated arcs.

· Fixed a problem with the G55/56/57/58 support for ‘C’ and ‘BonC’ rotating spindles (Type 5).

0.4.04e (4-14-08):
· Improved support for automatic arc feed rate calculation.

· Removed the “arcfeed=” settings from the wincnc.ini file.  All arc command feed rates will be calculated automatically, based upon the programmed velocity, arc radius, arc length and direction.

0.4.04f (4-22-08):
· Added improved error messaging for the Optimet laser digitization support.

· Updated Optimet laser digitization support to ensure accurate encoder counting during digitization.

· Removed support for integrated Daughterboard/PCI card.

· Updated the touch probe digitization commands (L82/L82.1/L82.2/L810/L811) to support digitization using vertical axis other than ‘Z’.

· Fixed a problem found in the smoothing feature when restarting a GCode file.
2.4.04 (5-6-08):
· Contains all features and fixes up to test version 0.4.04f.

0.4.05a (7-6-08):
· Updated auto-velocity calculation used to slow down for arc (G2/G3) moves.
· Added support for all axis to helical arc support.  3rd/4th/5th/6th axis specs can be added to G2/G3 commands regardless of type (vertical/rotational/etc.)
· Fixed a bug found in the M18.2 command used to test the state of auxiliary outputs.
· Fixed a bug found in the “watch=” setting used to generate a watchdog signal using an unused auxiliary output or timer pin.
· Updated the G28 command to fix a problem found with homing axis while using the axis mapping feature.
· Added axis letter and direction information to soft-limit abort messages.
2.4.05 (8-26-08):
· Contains all features and fixes up to test version 0.4.05a.

· Fixed a bug found in helical arc support added in a previous test version.
0.4.06a (9-5-08):
· Added abort functionality to the WinCNC communication API.

· Fixed a problem found when using the debounce setting with a digitizing touch probe.

0.4.06b (10-14-08):
· Updated the enable homing requirement feature.  Added a line to the WINCNC.INI file to configure options for the homing requirement.  Syntax is as follows:

G28REQ=I# T#

I# - ‘1’ requires homing of all axis on WinCNC startup and ‘0’ does not require homing on startup.

T# - ‘1’ disables transit until successful homing and ‘0’ does not disable transit.

· Added a separate limit debounce for use during G28.  Added a new setting to the WINCNC.INI file, syntax is as follows:

G28_LIM_CNT=#

# sets the limit debounce used during a G28.  The standard “LIM_CNT=” is used at all other times.

· Fixed a problem found in the L210.1 and L211.1 commands, used for switching port and bit values on alternate limit switches.

· Updated support for the newest version of the WINCNC.DLL communication API.  Added support for error status checking.

· Added a check on program startup to make sure that the WinCNC installation path does not contain spaces.  The WinCNC device driver service is automatically started and stopped when WinCNC is opened and closed.  The command line utility used to start/stop the service does not accept spaces in the path parameter.

· Added a maximum parameter setting to prevent problems that can occur from accidentally inputting an extremely large position parameter into one of the GCode commands.  This maximum parameter limit is applied in both the positive and negative directions.  The default maximum parameter is 99,999.  This value can be changed by adding the following line to the WINCNC.INI file:

MAXPARAM=#

# is the maximum parameter value for GCode commands in WinCNC.
0.4.06c (11-10-08):
· Fixed a problem found in full circle velocity calculations when using the “ARCTYPE=T1” (true arc) mode.

· Updated the Help->About dialog box to include all program features.

· Added a new button type to the WinCNC screen which allows the user to select a velocity percentage to use for rapid (G0/G53) moves.  Syntax in the CNCSCRN.INI file is as follows:

"RapidMode", X, Y, W, H, Mode, Unused, Label, Unused, Unused, ScanOn, ScanOff, Bitmap
Mode can be set to the following: 1=5%, 2=25%, 3=50%, 4=75%, and 5=100%

0.4.06d (12-1-08):
· Modified the THC support to include height control for laser cutting machines as well as plasma cutting.

· Added a software feature enable for the height control (THC/LHC) support.  All licenses purchased after daughter board revision 6.15 and serial #8184 will require a feature enable to activate the height control support.  Customers with boards sold prior to this can obtain the feature enable at no cost.

2.4.06 (12-2-08):
· Contains all features and fixes up to test version 0.4.06d.

0.4.07a (12-11-08):
· Fixed a bug found in the File->Restart dialog file history.

· Fixed a problem with using transit keys for manual height control via the “AXISADJ=T1” setting.

0.4.07b (1-9-09):
· Fixed a bug found in support for the PCI48H card.

· Updated the run time estimate in GCode simulate for improved accuracy.

· Added support for a rotating knife that can not exceed more than one full rotation, and must lift and unwind its position to stay within boundaries of 0 and 360 degrees.  Added a new setting the the “knifemode=” line in the WINCNC.INI file.  Syntax is as follows:

KNIFEMODE=... U#

# should be ‘0’ for a knife within infinite rotation capabilities (default) and ‘1’ for a knife that is capable of only a single full rotation.

0.4.07c (1-23-09):
· Updated support for rotating saw tools using the WINCNC.INI “sawmode=” setting.

· Added support for modifications made to the D/A circuit on daughter board revision 6.16.

· Added a new WINCNC.INI file setting to initialize virtual inputs to an on or off state.  By default the virtual input channel states are saved and restored when WinCNC is closed and reopened.  The syntax for setting a startup state is as follows:

“VIRTIN=C# I#”

C# is the virtual input channel number (1-64).

I# is the desired initialization state, 1 for on or 0 for off.

0.4.07d (2-23-09):
· Updated the file restart dialog list so that the most recently ran GCode file is automatically moved to the bottom of the list.

· Added a new parameter to the “RESTART=” setting in the WINCNC.INI file, used to specify the maximum number of files stored in the file restart dialog list.  The default number of files is 10.  Syntax for this setting is as follows:

RESTART=… M#

M# specifies the maximum number of files stored in the file restart dialog list.

· Updated the security key device read routine to resolve issues on certain computer systems running Windows XP and Windows Vista.

· Increased the maximum voltage allowed on the D/A setting for spindle speed control to 80 volts.

· Added a new type of rotating knife support, specified by adding a “T1” parameter to the “KNIFEMODE=” line in the WINCNC.INI file.  In this mode the rotating axis position is set as a target not an absolute, and as X or Y axis step pulses are output then step pulses are also output to the rotating axis as needed to reach its target position.  The position error is checked between moves, and an auto lift and rotate will occur when the error exceeds the “lift angle” as specified on the “KNIFEMODE=” line or set via the L30.1 command.  Using this mode allows the use of a rotating knife without effecting the speed or acceleration of the X or Y axis.

· Updated the GCode viewer to display internally generated rapid moves properly.

· Updated the L111, L111.1, and L112 commands for viewing, simulating, and file restarting.
· Fixed a bug found in unit conversion when using the THC feature.

0.4.07e (3-19-09):
· Added support to G2/G3 commands for an ‘R’ parameter to specifying the radius of the arc, which is used by some CAD/CAM programs in GCode creation.  This new parameter has been added as an addition to the standard method of ‘IJ’ parameters specifying incremental XY distances to the center point of the arc.

· Fixed a bug found in the “watch=” setting which can be utilized to generate a frequency for use as a “watchdog” signal that may be needed for external circuitry.  This fix pertains to the “watch=” modes that use the built in PCI7200 timers accessible on CN2 pins 11 and 15.

· Added a WinCNC startup log text file to record startup information while the software is performing startup tasks such as initializing memory, hardware, security features, etc.  The file, named STARTUP.LOG, is automatically created in the WinCNC program folder.  Each time that WinCNC is started the file is overwritten automatically.  This file is a useful diagnostic tool in identifying problems that may occur when starting the WinCNC software.

· Fixed a bug found in the “G28_LIM_CNT=” setting, which is used to specify a limit debounce value to be used automatically during a G28 command.  At all times, other than during a G28, the standard “LIM_CNT=” debounce value is used for limit sensing.

· Updated the security key read routine to resolve an intermittent failure on some PCs using Dual Core CPUs.

· Updating the loading of saved ATHC settings to protect against loading an invalid THC.POS file.

· Updated the saving and loading of position and workspace information for rotational axis.

· Added a new method of spindle speed control which uses CN2 pin 11 to generate a TTL square wave signal.  Many VFD spindle controls support this method of commanding spindle speed in addition to the already supported analog voltage and digital preset speed control methods.  As part of this update the feature enable for the DA feature in WinCNC has been renamed Spindle Speed, and all three types of spindle speed control are included when the Spindle Speed feature is purchased.  The new frequency output method of spindle speed control can be configured using the following WINCNC.INI syntax.
SPINDLE=T3 R28000 I0
[Frequency output/28000 RPM maximum/0 RPM initial default]

FREQ=L0 H100000

[0 Hz minimum/100 kHz maximum]

*Note that the minimum frequency that can be generated is 65 Hz.  Any speed command requiring a lower frequency will result in 0 RPM speed at the VFD.

*Note that the maximum frequency that can be generated is 2 MHz.  Any speed command requiring a higher frequency will result in maximum RPM speed at the VFD.

0.4.07f (3-31-09):
· Updated the laser bitmap engraving features to use the rapid acceleration rate during engraving.

· Updated error handing in the Auto-Run feature to handle enabling the Auto-Run feature when the specified directory or directories do not exist.

· Added a new enable input type 4, which allows non-motion and transit/jog moves but prevents motion commands from executing with the enable input is in the off state.

· Fixed a bug found in the G28, which in some cases would cause an axis to stop too abruptly upon the initial limit contact.

· Updated the spindle speed control feature to allow D/A function when using spindle speed control type 2.  This type of spindle speed control, usually used with a group of auxiliary outputs that are connected to the spindle VFD, calls a custom subprogram in response to a spindle speed command in a GCode file or from the WinCNC command line.

2.4.07 (4-2-09):
· Contains all features and fixes up to test version 0.4.07f.
0.4.08a (4-7-09):
· Added new workspace commands and INI settings for G58 and G59.  The commands and INI syntax for these are the same as for the original workspaces G54/G55/G56/G57.
· Fixed a bug found in the tool library where a blank space was being added to the beginning of tool descriptions for tool numbers greater than 10.

· Updated transit mode to ignore L11/L12 axis groupings.

0.4.08b (4-27-09):
· Fixed a bug found in the G54/G55/G56/G57/G58/G59 where offsets for vertical axis were not restored properly when switching between workspace modes.

· Fixed a problem with previewing GCode files containing automatic knife mode on/off commands.

· Updated the dual motor axis G28 homing to touch the primary and alternate limit switches separately to improve homing accuracy.

· Updated the dual motor axis G28 homing to ensure that both the primary and secondary motors are enabled when an abort occurs during a G28 command.

· Updated the vector laser support to use the “feed” acceleration rate even during rapid moves.  This increases machine stability and cut quality at the beginning of a vector laser contour.

· Updated the raster laser commands to restore the feed rate override to 100% and to disable the feed rate override slide control during a raster laser engraving.  Using feed rate override during laser engraving would cause problems with the bi-directional alignment offset, so feed rates must be set for XY prior to starting a laser engraving.

· Added a ‘V’ spec to the L10 array command.  Adding ‘V0’ to an L10 command will prevent the restoration of vertical axis positions between array elements.  The default or ‘V1’ operation will restore the position and G92 offset for any vertical axis between each element of the array.

0.4.08c (5-8-09):
· Fixed a problem with position normalization when the knife axis moves below 0 degrees or above 360 degrees when using the automatic rotating knife support.

· Updated the “ARCFEED=” setting in the WINCNC.INI.  3 to 20 “ARCFEED=R# F#” entries can be made to the WINCNC.INI file to specify the maximum feed rate that can be used with an arc move of a given radius.  When no “ARCFEED=” entries are found in the WINCNC.INI file then arc velocities are calculated automatically based on starting point, radius, and change of angle.
2.4.08 (5-12-09):
· Contains all features and fixes up to test version 0.4.08c.
0.4.09a (6-22-09):
· Removed support for SST servo serial gearshift feature.
· Fixed a problem with aborting during an arc (G2/G3) where original programmed feed rates where not restored properly.

· Fixed a problem with not being able to increase velocity using feed rate override during arcs if the “ARCFEED=” entries to control arc feed rate reduction are used in the WINCNC.INI.

· Updated all arc velocity algorithms to internally interpolate G2/G3 commands.

· Updated the rotating knife support to improve previewing/simulating GCode files.
· Updated the rotating knife support to resolve an issue with rolling over from 360 to 0 degrees.

· Fixed a problem found with quickly and repeatedly pressing transit keyboard keys, where a key release could be missed causing axis motion to continue.
0.4.09b (7-2-09):
· Fixed a problem with position normalization when the knife axis moves below 0 degrees or above 360 degrees when using the automatic rotating knife support.

0.4.09c (7-29-09):
· Fixed a problem with the arc radius error setting and unit conversion commands.
· Added a new parameter to the “KNIFEMODE=” line in the WINCNC.INI file.  Adding a ‘P#’ parameter will set the Z axis position for lowering the knife for cutting.  The default setting is 0 (zero).

· Updated the L30.1 command to include a ‘P#” parameter to set the Z axis position for lowering the knife for cutting.

· Fixed a problem with the smoothing on Z lifts immediately after interpolates G2/G3 commands.

· Fixed a problem with the automatic knife mode and G91 mode GCode files.

· Updated the G0 command to lift and rotate the knife in the direction of movement before moving other axis.

0.4.09d (9-3-09):
· Updated the M17.3, M18.3, M17.4, and M18.4 commands used for conditional logic in custom macros with “virtual” inputs.

· Modified the internal G28 homing routine to reset feed rate override to 100% prior to limit seeking.

· Updated support for the Optimet Mark3 digitizing laser probe to resolve issues with lost connection and lost encoder counts.

· Updated the real-time position display to resolve issues with unnecessary screen updates and rounding errors in converting integer step positions to the displayed floating decimal positions.

· Added support for helical arcs using G2/G3 commands by adding a K parameter to both commands for specifying the distance from arc start to arc center along the Z axis.  As with X and Y, if the Z axis ending position is not included on the G2/G3 line then a full circle is executed.
· Added a new function, Draw GCode, to the drop-down Options menu.  A hot-key is assigned to CTRL+G.  This allows the user to enable/disable the GCode viewer easily.  Some programs which send commands or GCode files directly to WinCNC to not prefer to have input focus transferred to WinCNC while the command is executing.  Temporarily disabling the GCode viewer while working in other applications will prevent this from happening.  An ‘I’ parameter has been added to the “TABLE=” line in the WINCNC.INI file to specify the default mode for the GCode viewer.  ‘I0’ sets the GCode viewer to be initially disabled and ‘I1’ sets the GCode viewer to be initially enabled.  The default mode for the GCode viewer initialization is enabled.

0.4.09e (9-16-09):
· Increased the maximum number of characters allowed in GCode files from 80 characters to 256.

· Updated velocity matching algorithm to improve matching between linear and rotary axis types.

· Fixed a bug in the “StateBtn” screen button entry where using multiple state button types could cause incorrect button up/down states.

· Updated the position display to resolve a problem with using WinCNC without the GCode view window enabled or active.

· Updated the File->Restart dialog box to include options to use or not use the vertical axis position restore, restart macro, restart feed macro, and restart first macro.  These variables are set in the WINCNC.INI as “RESTART=V#”, “CMDRESTART=”, “CMDRESTARTFEED=”, and “CMDRESTARTRAPID=”.  Checking or un-checking these boxes on the File->Restart dialog box will determine if the commands are used or not used during the file restart.
· Added support for G93/G94 commands to enable and disable inverse time-feed mode.  The G93 command will enable inverse time-feed mode.  When enabled this mode requires each G1 move to include an F# feed rate specification.  The feed rate for all moves on this G1 move will be automatically calculated so that each axis reaches its destination in 1/F minutes.  For example, “G1 X10 Y30 W360 F2”, would set feed rates so that each axis reaches its destination position in 30 seconds.  When inverse time-feed mode is active each G1 move MUST include an F# specification.  At this time G2/G3 moves are not supported in inverse time-feed mode.  The G94 command disables inverse time-feed mode.
0.4.09f (9-23-09):
· Updated demo mode to resolve problems with high axis step resolution settings causing slow speed.

· Updated position display to eliminate rounding errors in displayed positions.

· Updated the position display control group to indicate when G93 inverse time-feed mode is active.

· Fixed a problem found in the axis mapping setup that could cause a WinCNC program failure when exiting WinCNC.

· Updated the laser probe digitizing support to save changes made to the operation frequency of the Optimet laser probe.  Also added X# and Y# pixel offset amounts to the “LASERSCAN=” setting in the WINCNC.INI file.  When using a DPI resolution higher than the Windows default of 96, these parameters can be used to shift the custom controls and buttons on the laser probe dialog box to a visible position on the screen.  When using standard DPI settings these parameters will not be needed.

2.4.09 (9-23-09):
· Contains all features and fixes up to test version 0.4.09f.
0.4.10a (10-09-09):
· Fixed a problem with tool library values and unit conversions.

· Fixed a problem with G55 rotary spindle support and unit conversions.

· Enabled smoothing during rotation of spindle in G55 rotary spindle support.

0.4.10b (11-02-09):
· Updated laser digitizing feature.  Added an ‘O’ parameter to the LASERSCAN= line in the WINCNC.INI file.  An ‘O1’ or an ‘O-1” can be used to invert the direction of rotation for a rotary axis when used for digitization.  This determines the direction in which the digitized data is wrapped when the 3D mesh is produced.  This setting is determined by the orientation and positive/negative direction of motion of the rotary axis.  Also, laser digitizing has been disabled when the “QUADMODE” step/direction output method is selected.  The Optimet MarkIII laser probe no longer supported rising and/or falling edge triggers, so standard step/direction signals must be used.

· Updated the touch probe digitizing feature.  The File->Digitize->Automatic dialog box has been updated to allow the user to select each of the three axis used in digitizing (width/length/retract).  The width/length axis can be horizontal, rotational, or a combination of the two.  The retract axis must be vertical.  Before starting an automatic digitization make sure to position the width and length axis at the point where you wish to start scanning and also to position the retract axis above the highest point on the object being digitized.  When a rotational axis is selected the 3D mesh output is automatically wrapped around the Z0 position.  When digitizing with a rotary axis make sure to set a G92Z0 at the center of rotation.
· Fixed a bug found in unit conversion commands when using the G54/G55/G56/G57/G58/G59 workspace offsets.

· Updated the File->Open and File->Restart browse boxes to support file/path names up to 256 characters.

· Updated the default peck distance for the G73 peck drill cycle command.  The default lift is 0.05”.
· Updated the axis mapping feature to resolve an issue with velocity calculations for mapped axis.

· Updated error message customization.  All error messages have been added to the MESSAGES.INI text file for customization and language translation.  All error messages have an internal default.  The MESSAGES.INI file is available on request to users who would like to customize or translate the error messages output by WinCNC.

· Added a new text customization/translation file, MISCTEXT.INI, which contains all text lines used by pop-up message boxes in WinCNC.  All message box text lines have an internal default.  The MISCTEXT.INI file is available upon request to users who would like to customize or translate the text lines used in pop-up message boxes by WinCNC.
0.4.10c (11-19-09):
· Fixed a bug in viewing and simulating files containing L30/L31 commands for auto-rotating knife mode.

· Enabled G09 smoothing throughout arc (G2/G3) commands when auto-rotating knife mode is enabled.

· Added rotation and scaling support for DXF and HPGL importing.

· Fixed a problem with time-outs of the Optimet MarkIII laser digitizing probe.

· Added a bi-directional offset to the laser digitizing 3D output dialog.  This will allow the user to shift every second row of data in the 3D mesh to the left or right in order to align data acquired using the bi-directional laser digitizing option.

· Fixed a problem found with using the File->Restart feature with Options->Auto Preview enabled.  Using periods (.) in folder names would cause the file to always restart at line number 1.

0.4.10d (12-30-09):
· Fixed a bug found in the touch-probe outline digitizing support.
· Updated the command line parameter support to accept commands beginning with ‘/R=’.

· Added support for G74 left-hand tapping and G84 right-hand tapping commands.  Command syntax is G74/G84 Z# F# P#, where Z# sets the depth for the tap, F# sets the vertical feed rate, and P# sets the pitch of the tap.  Also, a new line was added to the WINCNC.INI file as follows:
G84SET=A# P# O#

A# sets the axis for tap rotation. (0=X, 1=Y, etc.)  The default is axis 3.

P# sets the default pitch for tapping.

O# can be set to 1 or -1 to invert the rotation direction.  The default is O1.

· Added a new screen component and L203.1 command which can be used to track the number of times a specified job file has been run.  Each time the specified file name is completed the count is incremented by one (1).  When the L203.1 command is executed the file name for counting is set and the total number of counts is reset to zero (0).

Syntax for the CNCSCRN.INI file is:

"Display", "JobCountWindow", Left, Top

Syntax for the WINCNC.INI file is:

L203.1=FILENAME.TAP

Syntax for the L203.1 command is:

L203.1 <FILENAME>
0.4.10e (1-7-10):
· Fixed a bug found in M37.3 command.  Adjusted tool measure positions were not being saved to SPOS.POS properly.

· Fixed a problem with bitmap engraving commands L252/L253/L254/L255.

· Updated the M98, M98.1, L201, L202, L203.1, and L252/L253/L254/L255 commands to accept file names containing spaces as a command parameter.  Previous versions would not accept file names as parameters to these commands if the file name or directory contained a space character.

· Fixed a problem were XY feed rates were restored at the end of a bitmap engrave incorrectly.  This problem occurred only when the X and Y axis were operating at different feed rates.

2.4.10 (1-13-10):
· Contains all features and fixes up to test version 0.4.10e.

0.4.11a (1-28-10):
· Added unit conversion for “old-style” ATC1 and ATC2 variables from WINCNC.INI.

· Added support for an optional subfolder to store INI files for language conversion.  WinCNC will first look into the “LANGUAGE” subfolder and then in the main program directory for the language conversion INI files.

· Added language conversion INI files for all dialog box text.  These INI files are available upon request for users who would like to do text customization or translation for any text lines or words used in WinCNC.  WinCNC now supports a complete set of INI files that allows customization and translation of all program text.
· Added a new WINCNC.INI setting, which will force all velocity scaling calculations for multi-axis moves to use step/second velocities, rather than the floating point velocities and 3D move lengths normally used.  In some cases, when the step/unit resolution of one axis is much larger or smaller than the step/unit resolution of other axis that are moving at the same time, the calculated velocity may be slower than expected.  In this case the user can add a “VSCALE=1” line to the WINCNC.INI file.  This forces all velocity calculations to be based on step/second velocities.  For 3rd and 4th axis 3D cutting specifically the original method should produce better results, but this setting has been added for use on machines where micro-stepping or electronic gearing is not an option.

· Fixed a problem found in initialization and start-up output states when using the 24H or 48H IO expansion PCI cards.

· Fixed a problem found in the L600 command, which is used to disable active axis mapping adjustments.

0.4.11b (2-16-10):
· Added two new internal variables, TD1 and TD2.  These variables can be used in GCode macros or subprograms to access the difference between the currently selected tool for ATC1 or ATC2 table position and the position stored in the ‘H0’ CNC.POS register.  The ‘H1’ position can be set using the M37 Z0 H1 command when the Z axis is at the location you wish to store.  TD1 returns the difference between the current ATC1 tool measure and the ‘H1’ stored location, and TD2 does the same for ATC2.  This is useful on ATC enabled setups for adjusting the G92Z position using a fixed material sensor or switch.

· Fixed a problem with transit move limits not updating when using the L22 and L23 commands to set axis boundaries.

· Added a new command used to change the limit switch debounce.  Command syntax is L901D#, where the D# is 1-30 to set the number or input read retries needed to confirm limit switch activation.

· Fixed a problem with using File->Restart were the file would start at an incorrect line number with the Options->Auto Preview option enabled.
· Added a new command for use with the laser height control.  The L48 command will set the target voltage to the current input voltage.

0.4.11c (2-22-10):
· Added a new setting to the “CUTCOMP=” line in the WINCNC.INI file.  The ‘E#’ value allows you to set the tolerance used for calculating circle/circle intersections when cutter compensation is active.  This can be increased from its default value of 0.0005” inches to resolve problems where circle intersection fails.  This can occur with inside offsetting of large arcs or circles with arc entry moves.
· Updated cutter compensation to resolve issues with modal G2/G3 commands.
· Updated the THC material configuration box.  A bug in the delete material button was fixed.  Three new fields, Slow Start Time, Slow Start Feed %, and Early Torch Off were also added.  These values can be accessed in macros and subprograms using variables THK for Slow Start Time, THV for Slow Start Feed %, and THQ for Early Torch Off distance.

· Added two new parameters to the L38 command, used for plasma torch on with THC support.  The T# parameter sets the slow start time and the P# parameter sets the feed rate percentage used for the slow start.  When both T# and P# parameters are used the cutting speed of the torch is reduced by P# % for T# seconds after the initial pierce.  Once T# seconds have expired the cutting speed returns to the originally specified feed rate.

· Added a new THC command, L39.1.  The command syntax is L39.1 T#, where the T# value is the distance from to the end of the last cut where the torch will turn off.  This command must be used prior to the L38 command to turn the torch on, and will result in the torch turning off prior to the end of the last cut move by the distance specified.

· Updated the DXF import option to support inverted X axis dimensions when the extrusion direction for a PolyLine or LWPolyLine entity is inverted.  This can occur when a mirror command is used to copy shapes in an array in some CAD programs.

· Fixed a bug found in the G28 homing command when axis mapping is active.

0.4.11d (3-1-10):
· Updated the Frame Scan dialog box to validate parameters before scanning starts.

· Updated velocity matching to resolve problems with moving multiple axes simultaneously when each axis has a significantly different step/unit resolution than the other axes that are moving at the same time.
· Updated the File->Restart feature to include two new options.  The “Skip to next feed move” option, when checked, will cause WinCNC to continue skipping lines after the specified line number is reached until the next G1/G2/G3 move is read.  The “Wait for user” option determines if WinCNC will pause for the user to confirm the restart point before cutting begins, or if it will start cutting immediately.  Both of these options have default values that can be specified on the “RESTART=” line in the WINCNC.INI file.  Adding ‘S0’ or ‘S1’ will set the default “skip to next feed move” option to enabled or disabled.  Adding ‘W0’ or ‘W1’ will set the default “wait for user” option to enabled or disabled.

· Updated the File->Restart feature to resolve problems with using G73/G74/G81/G82/G83/G84 drill cycle commands, G40/G41/G42 cutter diameter compensation commands, or the L38/L39/L39.1 plasma torch on and off commands.

· Fixed a problem with displaying incorrect sub-program file names when using the File->Restart feature.

0.4.11e (3-10-10):
· Updated the File->Restart feature to save G92 offset changes that can occur in macros called prior to restarting the file.

· Added error handling to loading commands and macros to protect against memory allocation issues.

0.4.11f (3-16-10):
· Updated the GCode viewer to improve speed and performance when reloading the same GCode file repetitively.

· Updated the GCode viewer to resolve a problem with using the Options->Auto Preview feature with GCode files containing unit of measure conversion commands G20, G21, G22, and G23.

· Fixed a problem where L91 and L90 commands for one-line incremental or relative moves were not reset properly during a user or limit abort.
0.4.11g (3-26-10):
· Updated the File->Restart feature to fix a bug introduced in the G92 offset update in a previous test version.

· Update the tangential knife feature to fix a bug introduced in the outline digitizing update in a previous test version.

· Updated the Configuration->Machine Settings menu option to be hidden unless the WinINIEditor.exe program is found in the main WinCNC program directory.

· Updated the S# spindle speed command to not generate an error message if the spindle speed control feature is not enabled.  The S# command will not work unless this feature is enabled.  Ignoring the command rather than generating an error message allows WinCNC to run GCode from CAD/CAM programs that include the S# command even when the spindle speed control option is not enabled.

2.4.11 (3-30-10):
· Contains all features and fixes up to test version 0.4.11g.

